[PDB-1760] PR (1534): (RE-5033) Update Ezbake to new 0.3.14 - stahnma Created: 2015/07/10  Updated: 2015/08/04  Resolved: 2015/07/13

Status: Closed
Project: PuppetDB
Component/s: None
Affects Version/s: None
Fix Version/s: PDB 3.0.1

Type: Task Priority: Normal
Reporter: gepetto-bot Assignee: Unassigned
Resolution: Fixed Votes: 0
Labels: github
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Template:
Story Points: 8
Sprint: PuppetDB 2015-07-15

 Description   

(RE-5033) Update Ezbake to new 0.3.14

Pull Request Description


Due to an odd issue with PuppetDB, when PuppetDB 2.3.z and PuppetDB
3.0.0 are in the same repository (e.g. PC1) you can not install
PuppetDB 2.3.z because the terminus package is oboleted and therefore
brings in the 3.0.0 version of temini. That means you can't really run
2.3.5. This is bad since the tests for PuppetDB 2.3.z test against the
AIO and Puppet 3.8 and so they need access to PC1.

As a fix, we're creating a new metapackage 'puppetdb-terminus' at
version 3 that wil require puppetdb-termini to allow for easier
transistion and upgrades. That, combined with the removal of
Obsoletes/Provides in the PuppetDB package will allow a user to use a
2.3.z or 3.0.0 release of PuppetDB.


(webhooks-id: 427bb09aa7f5eff7bf7b3e1648cac2ab)



 Comments   
Comment by gepetto-bot [ 2015/07/10 ]

pljenkinsro commented:

Test PASSed.
Refer to this link for build results (access rights to CI server needed):
https://jenkins.puppetlabs.com/job/platform_puppetdb_intn-sys_pr/1643/

Comment by gepetto-bot [ 2015/07/10 ]

pljenkinsro commented:

Test FAILed.
Refer to this link for build results (access rights to CI server needed):
https://jenkins.puppetlabs.com/job/platform_puppetdb_intn-sys_pr/1644/

Comment by gepetto-bot [ 2015/07/13 ]

Pull request (RE-5033) Update Ezbake to new 0.3.14 has been closed.

Generated at Mon Dec 16 05:01:12 PST 2019 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.