[PDB-847] PuppetDB 2.x is not compatible with Puppet Enterprise Created: 2014/08/29  Updated: 2016/04/27  Resolved: 2014/09/01

Status: Closed
Project: PuppetDB
Component/s: None
Affects Version/s: PDB 2.2.0
Fix Version/s: PDB 2.2.1

Type: Bug Priority: Blocker
Reporter: Ken Barber Assignee: Wyatt Alt
Resolution: Fixed Votes: 0
Labels: wtf
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Blocks
Template:
Story Points: 1
Sprint: 20140827 to 20140910

 Description   

Due to the Puppet version check introduced in 40c42e3, PuppetDB 2.x doesn't work with Puppet Enterprise. This happens because it tries to use the SemVer library to assert that Puppet.version is > 3.5.1. That check doesn't work in PE because Puppet.version is a string like 3.6.2 (Puppet Enterprise 3.4.0-rc1-601-gd369ee8) rather than a real semver. It's also a redundant check, because a) the puppetdb-terminus package has a hard dependency on puppet 3.5.1, and b) the version of puppet in PE will always be compatible with the version of PuppetDB in PE.


Generated at Thu Jun 20 02:49:09 PDT 2019 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.