[PDK-1008] Refactor to use puppet-runtime shared components Created: 2018/06/06  Updated: 2018/06/21  Resolved: 2018/06/19

Status: Closed
Project: Puppet Development Kit
Component/s: None
Affects Version/s: None
Fix Version/s: PDK 1.6.0

Type: Task Priority: Critical
Reporter: Bryan Jen Assignee: Unassigned
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Relates
relates to PA-1996 Install FFI on Linux platforms Needs Information
Template:
Team: Puppet Developer Experience
Release Notes: Not Needed
QA Risk Assessment: Needs Assessment

 Description   

Remove the rubygem-ffi component and other components shared with puppet-runtime from pdk-vanagon and start using the one provided by puppet-runtime so we can inherit common changes.

This will be required for 1.6.0 to include the patch for RE-10750



 Comments   
Comment by David Schmitt [ 2018/06/07 ]

See also PA-1996 with https://github.com/puppetlabs/puppet-runtime/pull/50

Generated at Thu Jan 23 01:08:37 PST 2020 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.