[PDK-1056] Add Ruby 2.5 to pdk-vanagon's 'additional_rubies' Created: 2018/06/27  Updated: 2018/10/09  Resolved: 2018/09/20

Status: Closed
Project: Puppet Development Kit
Component/s: None
Affects Version/s: None
Fix Version/s: PDK 1.7.1

Type: Task Priority: Normal
Reporter: Bryan Jen Assignee: Bryan Jen
Resolution: Fixed Votes: 0
Labels: resolved-issue-added
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Blocks
is blocked by PA-1882 Ruby 2.5 Closed
Template:
Epic Link: Add support for Puppet 6 to PDK, part 2
Team: Puppet Developer Experience
Release Notes: New Feature
Release Notes Summary: This adds Ruby 2.5.1 to the pdk package in support of testing against puppet 6.0 and above.
QA Risk Assessment: Needs Assessment

 Description   

PDK needs to add Ruby 2.5.x to the 'additional_rubies' list in pdk-vanagon so we can build the gem cache to support Puppet 6.

    • This may require adding Ruby 2.5 to puppet-runtime if it has not been added **

Generated at Wed Oct 16 03:24:32 PDT 2019 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.