[PDK-1208] Update lower bound of default puppet range for newly generated modules Created: 2018/10/24  Updated: 2018/11/29  Resolved: 2018/10/28

Status: Closed
Project: Puppet Development Kit
Component/s: None
Affects Version/s: None
Fix Version/s: PDK 1.8.0

Type: Task Priority: Normal
Reporter: Jesse Scott Assignee: Jesse Scott
Resolution: Fixed Votes: 0
Labels: resolved-issue-added
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Template:
Epic Link: PDK Maintenance
Team: Puppet Developer Experience
Release Notes: Enhancement
Release Notes Summary: Adding support for data-in-modules in the pdk template requires increasing the lower bound of the puppet requirement to ">= 4.10.0". This impacts newly generated modules.
QA Risk Assessment: Needs Assessment

 Description   

Since we merged the data-in-modules pull request and the oldest supported version of puppet has moved on, we should update the default puppet compatibility range for newly generated modules to have a lower bound of ">= 4.10".


Generated at Sat Jul 20 13:55:42 PDT 2019 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.