[PUP-2513] puppet module install fails when url includes basic auth Created: 2014/05/07  Updated: 2014/12/29  Resolved: 2014/12/29

Status: Closed
Project: Puppet
Component/s: PMT
Affects Version/s: PUP 3.2.4, PUP 3.5.1
Fix Version/s: None

Type: Bug Priority: Normal
Reporter: Michael Moghadas Assignee: Anderson Mills
Resolution: Incomplete Votes: 0
Labels: github, puppet, puppet-module
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Tested on OSX + CentOS


Issue Links:
Relates
relates to PUP-2869 Puppet should be able to use authenti... Closed
Template:
QA Contact: Kurt Wall

 Description   

When --module_repository is set to url that includes basic auth info like below...
'https://forgeuser:forgepassword@forgeserver.example.com/'

puppet module install will fail with following error:
Error: userinfo not supported. [RFC3986]
Error: Try 'puppet help module install' for usage

I've submitted following pull request for the fix:
https://github.com/puppetlabs/puppet/pull/2620



 Comments   
Comment by Anderson Mills [ 2014/12/29 ]

For now, the user has decided that they don't need the functionality that this ticket requested, and the PR was closed. Closing this issue.

Generated at Wed Apr 01 14:46:27 PDT 2020 using Jira 8.5.2#805002-sha1:a66f9354b9e12ac788984e5d84669c903a370049.