[PUP-2789] critical bug, windows agent : cant do some basic stuff (group creation, package installation, etc) Created: 2014/06/17  Updated: 2016/10/19  Resolved: 2016/09/22

Status: Closed
Project: Puppet
Component/s: Types and Providers
Affects Version/s: PUP 3.6.1, PUP 3.6.2
Fix Version/s: None

Type: Bug Priority: Normal
Reporter: Clement XaT Assignee: Clement XaT
Resolution: Cannot Reproduce Votes: 0
Labels: windows
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Xubuntu 14.04 for puppetmaster, Win7Entreprise64b for client


Attachments: File last_run_report.yaml     File nodes.pp     Text File output.txt     File puppet.bug.170614.tar.gz     File puppet.conf     File report.7z     File site.pp    
Issue Links:
Relates
relates to PUP-1542 Puppet::Util::Log requires a message Closed
Template:
Team: Agent
QA Contact: Narmadha Perumal

 Description   

Managing windows group doesn't working on my configuration.
I don't know why.
I tried to purge everything and start from fresh : first attemps worked (just the + group creation) then i worked a little about my manifests/modules with "minimal" code then error is back.

I think the group creation going bad because of.. i don't know and sending wrong thing to puppet agent (the Could not evaluate: Puppet::Util::Log requires a message) which send nil to somewhat which ended by "metric name nil is not a string"..

[gist] https://gist.github.com/XaaT/8ba53baf51cedc85e71c
Client side log : http://pastebin.com/XQ5yAYSF#
Server side log : http://pastebin.com/j4KcJUtC#

Server : x64 EN xubuntu 14.04 up to date with 3.6.2 puppetmaster, all last versions of puppet/facter/etc found on the apt repo
Client : x64 FR win7entreprise with last versions of puppet 3.6.2 and facter etc

I'm on the irc at XaT, please HL me if you want more informations.

edit : bugging too with package installation.

I reproduce bug with 3.6.2 linux puppetmaster (xubuntu 14.04) and 3.6.0/3.6.1/3.6.2 windows agent with this conf files : http://azora.fr:8080/archives/puppet.bug.170614-1.tar.gz (MINIMAL CODE ! One line.)

edit: adding FR relative to win7e



 Comments   
Comment by Josh Cooper [ 2014/06/17 ]

Clement XaT I'm having difficulty understanding what issue you are reporting. Please provide more information than "cant do some basic stuff".

From your error logs, it looks like you are trying to apply a set of different modules. Can you narrow this down to a specific module? We will need a sample manifest that demonstrates the issue. If you can reproduce the problem in a simple scenario, please run `puppet agent -td --trace` and attach the backtrace to this ticket. I'm assigning this to you for more information.

Comment by Clement XaT [ 2014/06/18 ]

Sorry, my english is not great.
The issue happend with this minimal configuration ( http://azora.fr:8080/archives/puppet.bug.170614-1.tar.gz ), just one line on manifests/site.pp
I'll get the trace and give it to you in few moments.
Please note that i'm using french windows 7 enterprise as client(s).

XaT

Comment by Clement XaT [ 2014/06/18 ]

Added report.7z with output from puppet agent -td --trace command and last_report.yaml (if needed..)

Comment by Ethan Brown [ 2014/12/04 ]

Clement XaT there appears to be an issue here when manipulating a group:

Error: /Group[testgroup344]: Could not evaluate: Puppet::Util::Log requires a message

However, I don't see any manifest code that shows the group declaration, so it's hard to diagnose this problem. If you have a manifest declaration that would be useful.

I would also take a look at PUP-2628 which describes an issue that occurs when manipulating group membership on Windows.

Comment by Josh Cooper [ 2015/07/13 ]

Clement XaT can you provide the manifest showing the group resource Ethan Brown was mentioning? Can you reproduce the issue using only the group resource?

Comment by Moses Mendoza [ 2016/09/22 ]

This ticket has not been updated in some time and is now closed due to inactivity. If any viewer/watcher feels this is inaccurate, please re-open this ticket.

Generated at Thu Jun 20 02:13:50 PDT 2019 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.