[PUP-3060] Remove Warning on Ruby 2.0 / Windows about "DL is deprecated, please use Fiddle" Created: 2014/08/14  Updated: 2016/10/19  Resolved: 2014/08/18

Status: Closed
Project: Puppet
Component/s: None
Affects Version/s: PUP 3.6.2
Fix Version/s: PUP 3.7.0

Type: Task Priority: Normal
Reporter: Ethan Brown Assignee: Unassigned
Resolution: Fixed Votes: 0
Labels: windows
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Relates
relates to PUP-2396 Support ruby 2.0 x64 on windows Closed
relates to PUP-3832 Remove Warning on Ruby 2.1/ Windows a... Resolved
Template:
Epic Link: Windows ruby x64
Story Points: 1
Sprint: 2014-08-20

 Description   

This is more of a nuisance message than anything else, and should be removed from our distribution so as to not confuse users.

More details on DL vs Fiddle here:

http://stackoverflow.com/questions/15590450/ruby-2-0-0p0-irb-error-dl-is-deprecated-please-use-fiddle



 Comments   
Comment by Josh Cooper [ 2014/08/18 ]

Previous behavior:

C:\work\puppet [master +12 ~0 -0 !]> .\ext\envpuppet puppet resource user Administrator
DL is deprecated, please use Fiddle
user { 'Administrator':
  ensure  => 'present',
  comment => 'Built-in account for administering the computer/domain',
  groups  => ['Fundamentals', 'Administrators'],
  uid     => 'S-1-5-21-2397885826-1833024046-1055597067-500',
}

With change:

C:\work\puppet [master +12 ~0 -0 !]> .\ext\envpuppet puppet resource user Administrator
user { 'Administrator':
  ensure  => 'present',
  comment => 'Built-in account for administering the computer/domain',
  groups  => ['Fundamentals', 'Administrators'],
  uid     => 'S-1-5-21-2397885826-1833024046-1055597067-500',
}

Generated at Thu Nov 14 00:59:52 PST 2019 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.