[PUP-3610] external facts copied over via pluginsync dont show up when facter runs Created: 2014/11/03  Updated: 2016/10/19  Resolved: 2014/11/10

Status: Closed
Project: Puppet
Component/s: None
Affects Version/s: PUP 3.7.2
Fix Version/s: None

Type: Bug Priority: Normal
Reporter: Dan McManus Assignee: Unassigned
Resolution: Duplicate Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Red Hat Linux 6.5


Issue Links:
Blocks
blocks PUP-578 (PR) Support pluginsync of external f... Closed
Duplicate
duplicates FACT-696 facts.d module "external" facts get p... Closed
Relates
relates to FACT-96 Deprecate 'facter --puppet' Closed
Template:
QA Contact: Erik Dasher

 Description   

Running puppet 3.7.2 on both the master and the client. The issue is that although external facts are being copied to the client during the puppet run, the do not turn up when I run facter -p.

They do run when I run "facter --external-dir=/var/lib/puppet/facts.d/"

Also, they show up when I run puppet apply -e 'alert ($::<my_external_fact>)'.

So Puppet sees it, but facter doesn't without pointing it to the dir.



 Comments   
Comment by Josh Cooper [ 2014/11/10 ]

Historically, external facts only appear when puppet executes facter, but not when facter is run stand-alone with or without the --puppet option.

Generated at Thu Apr 09 07:00:19 PDT 2020 using Jira 8.5.2#805002-sha1:a66f9354b9e12ac788984e5d84669c903a370049.