[PUP-3618] Include pkgng provider for FreeBSD Created: 2014/11/04  Updated: 2019/04/04  Resolved: 2015/05/20

Status: Closed
Project: Puppet
Component/s: Types and Providers
Affects Version/s: None
Fix Version/s: PUP 4.1.0

Type: Bug Priority: Minor
Reporter: Zach Leslie Assignee: Branan Riley
Resolution: Done Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Template:
Story Points: 1
Release Notes: New Feature
QA Contact: Eric Thompson

 Description   

Rather than require a module to implement this functionality, Puppet should ship with the new provider and update existing ones to deprecate functionality where no longer required.

risk: low



 Comments   
Comment by Zach Leslie [ 2014/11/04 ]

https://github.com/puppetlabs/puppet/pull/3276

Comment by Adrien Thebo [ 2014/11/05 ]

Since this may be a breaking change I'm targeting it at 4.0.0.

Comment by Zach Leslie [ 2015/03/20 ]

I've updated the PR. Is there other information I can provide?

Comment by Kylo Ginsberg [ 2015/04/22 ]

This passed CI and we don't do in-house functional review for FreeBSD so resolving.

Generated at Mon Dec 09 13:06:00 PST 2019 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.