[PUP-3740] Update puppet package dependencies to require ruby 1.9.3 or greater Created: 2014/12/04  Updated: 2019/04/04  Resolved: 2016/05/10

Status: Closed
Project: Puppet
Component/s: None
Affects Version/s: None
Fix Version/s: PUP 4.5.0

Type: Bug Priority: Normal
Reporter: Josh Cooper Assignee: Unassigned
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
is blocked by PUP-2563 Remove 1.8.7 support in the ruby code... Closed
Story Points: 2
Sprint: Client 2016-05-18
Release Notes: Bug Fix
Release Notes Summary: Puppet 4 introduced a requirement on ruby 1.9.3 or greater, however the gemfile didn't properly state that requirement. As of puppet 4.5.0 it now does.


Update rpm, deb, gem packages to require ruby 1.9.3 as puppet will no longer run on pre-1.9.3.

Comment by Michael Stahnke [ 2014/12/04 ]

This should be covered by the All in One agent work. /cc Past Haus

Comment by Josh Cooper [ 2014/12/04 ]

There's also puppet as a gem

Generated at Mon Feb 24 16:08:10 PST 2020 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.