[PUP-4437] Update the "puppet-agent" Repo for 4.0.1 to Incorporate Fix for PUP-4390 Created: 2015/04/17  Updated: 2015/05/20  Resolved: 2015/05/20

Status: Closed
Project: Puppet
Component/s: Windows
Affects Version/s: PUP 3.7.0
Fix Version/s: PUP 3.8.1, PUP 4.1.0

Type: Bug Priority: Critical
Reporter: Ryan Gard Assignee: Rob Braden
Resolution: Done Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Relates
relates to PUP-4390 Regression: Windows service provider ... Closed
Template:
Release Notes: Bug Fix
QA Contact: Kurt Wall

 Description   

The original ticket PUP-4390 affects the PE 3.8 release and needs to be validated and closed soon. To unblock the work I have created this separate ticket to track the work of merging the fix for PUP4390 in the 4.0.1 pipeline. See linked ticket for more details.

QA Risk Analysis

Refer to related bug, PUP-4390



 Comments   
Comment by Melissa Stone [ 2015/04/23 ]

On the aardwolf branch of puppet agent, we have windows ruby set to

{
  "url": "git://github.delivery.puppetlabs.net/puppetlabs-puppet-win32-ruby.git",
  "ref": {
    "x86": "refs/tags/2.1.6.0-x86",
    "x64": "refs/tags/2.1.6.0-x64"
  }
}

both the 2.1.6.0-x86 tag and the 2.1.6.0-x64 tag include Ethan's commits that fix PUP-4390

Comment by Nicholas Fagerlund [ 2015/04/27 ]

Housekeeping: I'm targeting this at the version it seems to affect, instead of 3.8.0. There's already a 3.8.0 ticket covering this fix.

Comment by Henrik Lindberg [ 2015/05/18 ]

This fix seems to also be in 3.8.1 (updated the Fix version), but the commit b9c6b9b is tagged with the ticket PUP 4390 which is targeting 3.8.0.

Generated at Sat Dec 14 01:52:00 PST 2019 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.