[PUP-5608] Add initial ruby 2.3 support Created: 2015/12/14  Updated: 2016/08/15  Resolved: 2015/12/15

Status: Closed
Project: Puppet
Component/s: None
Affects Version/s: None
Fix Version/s: PUP 4.4.0

Type: New Feature Priority: Normal
Reporter: Kylo Ginsberg Assignee: Unassigned
Resolution: Fixed Votes: 0
Labels: puppethack
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Blocks
blocks PA-402 Bump puppet-agent's vendored Ruby to 2.3 Closed
Template:
Epic Link: Update puppet-agent to use Ruby 2.4
Story Points: 1
Sprint: Client 2015-12-16
Release Notes: New Feature
Release Notes Summary: This adds initial Ruby 2.3 support. However, note that using puppet with ruby 2.3.0 is not recommended yet.

 Description   

Ruby 2.3 will be released Dec 25 2015, so we should add support. To be clear, bumping puppet-agent to include ruby 2.3 is not planned at all. This ticket is just to enable specs to pass with ruby 2.3 and to enable it in travis ci.



 Comments   
Comment by Kylo Ginsberg [ 2015/12/14 ]

I have a PR that I can put up for this.

Generated at Wed Nov 13 11:42:33 PST 2019 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.