[PUP-6564] Support Ruby 2.3.x with Puppet 4.5.2 Created: 2016/07/28  Updated: 2017/03/23  Resolved: 2017/03/23

Status: Closed
Project: Puppet
Component/s: None
Affects Version/s: PUP 4.5.2
Fix Version/s: None

Type: Bug Priority: Normal
Reporter: Ravi Shankar Assignee: Unassigned
Resolution: Incomplete Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Linux, Windows, Unix


Issue Links:
Relates
relates to PA-476 Update puppet-agent to use Ruby 2.4 Closed
Template:
Team: Agent

 Description   

Ruby 2.1.9 is the highest version tested and supported for Puppet 4.5.2.
Please support the recent version of Ruby 2.3.x which is supported for longer term.



 Comments   
Comment by Josh Cooper [ 2017/03/23 ]

Thank you for reporting this. This issue has already been addressed in a later release of Puppet. If you experience this issue against the current version of Puppet, please add a comment to this ticket with your reproduction scenario.

For more info on getting the current version of Puppet Agent, see https://docs.puppet.com/puppet/latest/install_pre.html.

Generated at Fri Jan 17 18:42:56 PST 2020 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.