[PUP-7781] yumrepo don't support payload_gpgcheck option Created: 2017/07/15  Updated: 2018/02/15  Resolved: 2017/11/09

Status: Closed
Project: Puppet
Component/s: Types and Providers
Affects Version/s: PUP 5.0.0
Fix Version/s: PUP 5.4.0

Type: Bug Priority: Normal
Reporter: Max Mustermann Assignee: Unassigned
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

CentOS/RHEL 7.4


Template:
Team: Platform Core
Sprint: Platform Core KANBAN
Method Found: Customer Feedback
Release Notes: New Feature
Release Notes Summary: Puppet now supports the payload_gpgcheck option to yum.
QA Risk Assessment: No Action

 Description   

Since RHEL 7.4 an new yum repo option is available to verify the payload of an rpm package.
See here for the description of it.



 Comments   
Comment by Thomas Mueller [ 2017/07/15 ]

Max Mustermann I've created a PR: https://github.com/puppetlabs/puppet/pull/6075

Comment by Moses Mendoza [ 2017/10/13 ]

merged to master at https://github.com/puppetlabs/puppet/commit/7fd083ea3d60f73664dcf51e0f69fb10b1ad32a6

Generated at Fri Jan 24 23:22:34 PST 2020 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.