[PUP-7816] Package resource' ensure attribute to use Semantic Versioning Created: 2017/08/03  Updated: 2018/05/21

Status: Accepted
Project: Puppet
Component/s: Types and Providers
Affects Version/s: None
Fix Version/s: None

Type: New Feature Priority: Normal
Reporter: Matthew Patton Assignee: Unassigned
Resolution: Unresolved Votes: 0
Labels: package, resources, type_and_provider
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Relates
relates to PUP-5541 Package resources should support pess... Accepted
Template:
Team: Platform OS
QA Risk Assessment: Needs Assessment

 Description   

I wanted to ensure that puppet-agent 1.9.0 was not allowed on my boxes and realized there was no way for me to do so without resorting to RPM version string. I don't want to pin it to 1.8.4 or 1.9.2, nor do I want to play roulette and specify 'latest' since broken builds show up from time to time. I should be able to specify the well-known nomenclature that Module metatdata.json uses.

ensure =>  ">= 4.8.2 < 5.0.0"

References



 Comments   
Comment by Henrik Lindberg [ 2018/05/14 ]

Not sure how this can be made to work since not all package managers use Semver.

Generated at Sun Jul 21 01:27:54 PDT 2019 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.