[PUP-7899] acceptance: Update aix package test to validate 'ensure => latest' Created: 2017/09/01  Updated: 2018/02/15  Resolved: 2017/09/28

Status: Closed
Project: Puppet
Component/s: None
Affects Version/s: None
Fix Version/s: PUP 5.4.0

Type: Task Priority: Normal
Reporter: John Duarte Assignee: Erik Dasher
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Relates
relates to PUP-6364 On AIX, an already installed package ... Closed
Template:
Team: Platform OS
Story Points: 1
Sprint: Platform OS 2017-09-05, Platform OS 2017-09-19, Platform OS 2017-10-03
Release Notes: Not Needed
QA Risk Assessment: Automate

 Description   

PUP-6364 addressed a flaw in the AIX package provider where using 'ensure => latest' failed to upgrade a package if it was already installed. The existing acceptance test for the AIX package provider needs to be updated to ensure that the desired behavior for this meta-parameter does not regress.


Generated at Sat Aug 08 08:00:57 PDT 2020 using Jira 8.5.2#805002-sha1:a66f9354b9e12ac788984e5d84669c903a370049.