[PUP-8179] pip3 provider fails on windows 10 Created: 2017/11/15  Updated: 2019/04/04  Resolved: 2018/01/17

Status: Closed
Project: Puppet
Component/s: Windows
Affects Version/s: None
Fix Version/s: None

Type: Bug Priority: Major
Reporter: david verenzuela Assignee: david verenzuela
Resolution: Won't Fix Votes: 0
Labels: Community, Windows
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Windows 10


Template: PUP Bug Template
Acceptance Criteria:

To add the pip3.exe option to the provider package.

Sub-team: Coremunity
Team: Platform Core
Method Found: Needs Assessment
QA Risk Assessment: Needs Assessment

 Description   

I have found an issue in windows 10 using the pip3 provider. In the puppet agent execution we noticed the error message:

"change from absent to present failed: Could not set 'present' on ensure: Could not locate command pip3"

I have manually tried to copy the pip3.exe to pip3 and the issue was solved.

Checking the puppet code I did a PR with my proposed changes:
https://github.com/puppetlabs/puppet/pull/6366

Thanks.



 Comments   
Comment by Melissa Stone [ 2018/01/17 ]

Pull request: https://github.com/puppetlabs/puppet/pull/6366

Since this hasn't seen any activity in over two months, I'm going to go ahead and close this ticket for the time being. Please re-open this ticket once the next actions are addressed, new information is available, or you have a question related to this pull request. We've become aware of difficulties re-opening pull requests, in the event you cannot please mention melissa with an @ sign in front and we'll re-open this ticket.

Closing the pull request doesn't mean we don't consider this change valuable, just that there are things that need to be addressed before it can be merged. If you have any questions or concerns, please don't hesitate to ping us in slack.puppet.com.

Generated at Sun Aug 25 05:09:02 PDT 2019 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.