[SERVER-1787] Fix Puppet 3 Compatibility tests error installing puppet 3.8 on EL with Beaker 3.12 Created: 2017/04/24  Updated: 2017/06/21  Resolved: 2017/06/02

Status: Closed
Project: Puppet Server
Component/s: None
Affects Version/s: None
Fix Version/s: SERVER 5.0.0

Type: Bug Priority: Normal
Reporter: Ruth Linehan Assignee: Adrien Thebo
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Template:
Team: Systems Engineering
Sub-team: Server
Story Points: 1
Sprint: Server 2017-06-28
Release Notes: Not Needed
QA Risk Assessment: Needs Assessment

 Description   

The Puppet 3 compatibility tests fail to install Puppet 3.8 on EL with Beaker 3.12+. This is due to the change in https://github.com/puppetlabs/beaker/commit/688a1c8b4042723fb578f2ded19e63c8e0c32ed4#diff-27026e05f9aa40b65dcfab171a40e73c.

In the Puppet 3 compat tests we set type to aio. However, the agent we run is technically not aio - it needs to install Puppet 3.8. So we need the non PC1 url. We need to figure out how to set the agent/modify the agent so it has type foss or nil.


Generated at Tue Aug 11 00:50:04 PDT 2020 using Jira 8.5.2#805002-sha1:a66f9354b9e12ac788984e5d84669c903a370049.