[SERVER-2157] Package jruby in puppetserver jar Created: 2018/03/20  Updated: 2018/04/09  Resolved: 2018/04/09

Status: Closed
Project: Puppet Server
Component/s: Puppet Server
Affects Version/s: None
Fix Version/s: SERVER 6.0.0

Type: Improvement Priority: Normal
Reporter: Patrick Carlisle Assignee: Maggie Dreyer
Resolution: Fixed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Template:
Epic Link: Remove JRuby 1.7
Team: Server
Release Notes: New Feature
Release Notes Summary: Puppet Server now bundles its JRuby jar inside the main uberjar. This means the JRUBY_JAR setting is no longer valid, and a warning will be issued if it is set.
QA Risk Assessment: Needs Assessment

 Description   

Since we don't need to choose the jruby version anymore we could ship this directly now and it will make AOT easier.

 

This should also remove support for JRUBY_JAR and issue a warning if it is set.


Generated at Thu Nov 21 03:21:59 PST 2019 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.