[SERVER-2191] Change default JRUBY_JAR to 9k Created: 2018/04/17  Updated: 2018/04/17  Resolved: 2018/04/17

Status: Closed
Project: Puppet Server
Component/s: None
Affects Version/s: None
Fix Version/s: None

Type: Improvement Priority: Normal
Reporter: Peter Souter Assignee: Unassigned
Resolution: Duplicate Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Duplicate
duplicates SERVER-2095 Bump default jruby from 1.7.27 to 9k Closed
Relates
relates to SERVER-1998 Bundled ruby throws error on net/http... Closed
relates to SERVER-1630 Support user configuration of JRuby 1... Closed
relates to ENTERPRISE-1164 Not possible to configure jruby_jar s... Closed
Template:
QA Risk Assessment: Needs Assessment

 Description   

Right now, there are conflicts with any gems that require Ruby 2.1 features

eg. https://github.com/davealden/hiera-vault/issues/5

Since the version of Ruby used within JRuby < 9k is 1.9.1, which is EOL, it would be nice to default to the newer JRUBY_JAR in the config setting



 Comments   
Comment by Peter Souter [ 2018/04/17 ]

headius commented on 21 Nov 2017
JRuby 1.7.27 appears to be sufficient as a last release for 1.7. We shall call 1.7 officially EOL now.

https://github.com/jruby/jruby/issues/4112#issuecomment-242504130

Comment by Charlie Sharpsteen [ 2018/04/17 ]

Duplicate of SERVER-2095.

  • Open Source Puppet Server will be moving to 9k in the 6.0 release, 1.7 will no longer be available.
  • The upcoming PE 2018.1 release will use Puppet Server 5.3, but with the default changed to 9k, 1.7 will be available as a fall-back in case some compatibility issue pops up.
Comment by Peter Souter [ 2018/04/17 ]

Awesomesauce, thanks Charlie Sharpsteen!

Generated at Wed Oct 16 02:08:23 PDT 2019 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.