[SERVER-2461] Update jline to 2.12 or greater Created: 2019/02/14  Updated: 2019/07/10

Status: Accepted
Project: Puppet Server
Component/s: None
Affects Version/s: None
Fix Version/s: SERVER 6.0.z, SERVER 6.3.z, SERVER 6.y

Type: Task Priority: Normal
Reporter: Maggie Dreyer Assignee: Unassigned
Resolution: Unresolved Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Blocks
is blocked by SERVER-2388 Update JRuby to latest version -- che... Resolved
Template:
Team: Froyo
QA Risk Assessment: Needs Assessment

 Description   

Because a security vulnerability, jline needs to be updated to at least 2.12. This requires us to update JRuby, since it is shipped with JRuby. That update is tracked in SERVER-2388.


Generated at Mon Jan 27 11:12:15 PST 2020 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.