[SERVER-540] puppetserver 1.0.8-1puppetlabs1 no longer honours proxy for installing gems Created: 2015/04/09  Updated: 2015/12/30  Resolved: 2015/04/09

Status: Closed
Project: Puppet Server
Component/s: Puppet Server
Affects Version/s: SERVER 1.0.8
Fix Version/s: None

Type: Bug Priority: Minor
Reporter: Merritt Assignee: Unassigned
Resolution: Duplicate Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Issue Links:
Relates
relates to SERVER-377 "puppetserver gem" command doesn't wo... Closed
Template:

 Description   

When using puppet server 1.0.8, I can no longer install gems via our proxy server:

puppetserver gem install hiera-eyaml -v 1.1.4
ERROR: Could not find a valid gem 'hiera-eyaml' (= 1.1.4), here is why:
Unable to download data from https://rubygems.org/ - Errno::ECONNREFUSED: Connection refused - Connection refused (https://rubygems.org/specs.4.8.gz)

Downgrading to 1.0.2-1puppetlabs1 resolved this issue for me:
puppetserver gem install hiera-eyaml -v 1.1.4
Fetching: trollop-2.1.2.gem (100%)
Successfully installed trollop-2.1.2
Fetching: highline-1.7.1.gem (100%)
Successfully installed highline-1.7.1
Fetching: hiera-eyaml-1.1.4.gem (100%)
Successfully installed hiera-eyaml-1.1.4
3 gems installed



 Comments   
Comment by Jeremy Barlow [ 2015/04/09 ]

This sounds like it might be a duplicate of SERVER-377. Can you take a look at that and see if you agree? If so, I'd suggest we close this as a duplicate.

Comment by Merritt [ 2015/04/09 ]

Yes it is a duplicate, sorry for wasting your time.

Comment by Jeremy Barlow [ 2015/04/09 ]

Oh, no problem. I'll close this one, then.

Generated at Mon Jan 27 11:53:11 PST 2020 using JIRA 7.7.1#77002-sha1:e75ca93d5574d9409c0630b81c894d9065296414.